PDA

View Full Version : sorry to ask so many q"s



Finny
02-13-2008, 07:02 PM
I have 2 clowns, one has been staying at the bottom for the last 4 days (it will swim to the top to get food, then goes back to the bottom), the other is hiding. I gave them some mysis shrimp soaked in garlic water because I thought they were sick.

They had been eating the brine shrimp, but they ran from the mysis shrimp. The anenomae is happy, but the clowns came out, looked at the shrimp and went back to hiding.

I have a book on Clowns, and it said to look for parasites. I've used a magnifying glass and can't find any.

I'm afraid I'm losing them. All the water readings were perfect when I added the clowns last thursday. They are still well within the parameters necessary.

What else can I do?

phoenix001
02-13-2008, 10:26 PM
Can you post your water parameters? I hear you say the params are fine, but something is clearly wrong. How did you acclimate the fish? Your tank is very young (1 month according to profile) so its possible your still cycling.

L8-NiTe
02-13-2008, 10:34 PM
Yea and i seen she had some brown algea forming on sand,im guessing the tank wasnt fully cycled.

Coral Pets
02-14-2008, 06:21 PM
Clowns are usually really hardy fish. I used them way back when to cycle tanks. Are they thinning at all? Mysis can be a bit big for small clowns to eat. Have you went back to the brine shrimp? Try some crushed up flake food.

only_mnh
02-21-2008, 02:59 AM
It will take a little while to get everything equalized. Put your thermometer into the filter compartment, with the carbon. And maybe point your flow towards the opposite corner?!? You know, surprise them.